Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name

Welcome to!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Thread Tools Rate Thread Display Modes
Old 12-05-2012, 07:27 AM   #1
1st Gear Newbie
Join Date: Jul 2011
Location: barrington, il
Posts: 20
1994 740i

Hello people,

I need some help with my 94 740I. Just in the last two days when i put the car in gear it doesn't seem to be in first gear. i touch the gas and it sort of just sits there and than it starts to role and than catches and jumps. It's not as bad as all that but it's definitely something new and worrisome. Am i loosing my trans?

thanks in advance,
dsheetz is offline   Reply With Quote
Old 12-05-2012, 09:28 AM   #2
Founder of GTA7's
740-iLL's Avatar
Join Date: Apr 2004
Location: Brampton
Posts: 1,094
Sounds like a Transmission issue to me.

I would give Bob or Mathew @ Toronto Automatic Transmissions a call. Best Trans shop in the GTA for our vehicles!

Follow me on Twitter @SEVEN40iL
740-iLL is offline   Reply With Quote
Old 12-05-2012, 06:21 PM   #3
2nd Gear Member
Join Date: Apr 2012
Location: Ottawa
Posts: 173
Somebody has to ask: Fluid level OK?
SubDad is offline   Reply With Quote

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

All times are GMT -4. The time now is 04:07 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2015