Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-25-2012, 10:18 AM   #1
Klipzs
1st Gear Newbie
 
Join Date: Feb 2012
Location: Canada
Posts: 43
car was about to die in the middle of the intersection

On my way driving to the train station, I stopped at a traffic light to make a turn. I then realize that the car started vibrating slightly and that was due to rough rpm ( about 500rpm). The battery light then started flickering. If I haven't given the car gas during the intersection, the car probably would have stalled. Car seems fine at normal speed but when driving slow(5-20km per hour) this happens.
What could possibly be the problem?
Klipzs is offline   Reply With Quote
Old 04-25-2012, 11:18 AM   #2
slemmer
Driving in the fast lane
 
slemmer's Avatar
 
Join Date: Dec 2002
Location: Missed in 'sauga
Posts: 2,995
Dirty o2 sensors?
__________________

'04 645cic
'05 GMC Sierra SLT Z71 CCSB 4x4
'02 Regal LS
'00 740i Sport
slemmer is offline   Reply With Quote
Old 04-25-2012, 01:50 PM   #3
e30drifter
SLYDWAYZ
 
e30drifter's Avatar
 
Join Date: Apr 2007
Location: east york
Posts: 277
Alternator
__________________

http://youtube.com/watch?v=JUpYp5eqTbk-(GO NUTS FOR DONUTS)
"if you think education is difficult, you should try being stupid"
e30drifter is online now   Reply With Quote
Old 04-25-2012, 01:52 PM   #4
Klipzs
1st Gear Newbie
 
Join Date: Feb 2012
Location: Canada
Posts: 43
Alernator is a bosche brand and was replaced a year and a half ago.
Klipzs is offline   Reply With Quote
Old 04-25-2012, 02:25 PM   #5
Eurostyle
MaXsponsor
 
Eurostyle's Avatar
 
Join Date: Feb 2002
Location: Milton
Posts: 14,997
Vacume leaks or alternator. Most othe problems will just cause a check engine, run in limp mode, but not actually stall.
__________________
BIMMER HEAVEN
Specialized in BMW recycling, all OEM used parts
Up to 90% off new cost!!!
Most models E30 E36 E46 E90 E92 E93 E34 E39 E60 E32 E38 E65 E66 X3 X5 M3 M5 Z4


2nd location opening SOON!!!!

Call 11-8PM 416 821-2578
New inventory daily. 50+ cars in stock!
Eurostyle is offline   Reply With Quote
Old 04-25-2012, 03:31 PM   #6
Klipzs
1st Gear Newbie
 
Join Date: Feb 2012
Location: Canada
Posts: 43
Will I have a small evap light last time I checked. I'm not sure this problem could be.
Klipzs is offline   Reply With Quote
Old 05-02-2012, 02:38 AM   #7
Klipzs
1st Gear Newbie
 
Join Date: Feb 2012
Location: Canada
Posts: 43
Ok so I got my codes scanned and got P0442 and P1250.
P0442 is the small evap light my mechanic was talking about.
But what about P1250? Someone mentioned that P1250 was the fuel filter but what fuel filter cause my battery light to flicker when my car was about to die?
Klipzs is offline   Reply With Quote
Old 05-04-2012, 10:28 PM   #8
BmW1819
6th Gear Member
 
Join Date: Feb 2007
Location: Pickering
Posts: 2,802
light came on cause car almost stalled
BmW1819 is offline   Reply With Quote
Old 05-04-2012, 11:01 PM   #9
Eurostyle
MaXsponsor
 
Eurostyle's Avatar
 
Join Date: Feb 2002
Location: Milton
Posts: 14,997
Quote:
Originally Posted by Klipzs View Post
Ok so I got my codes scanned and got P0442 and P1250.
P0442 is the small evap light my mechanic was talking about.
But what about P1250? Someone mentioned that P1250 was the fuel filter but what fuel filter cause my battery light to flicker when my car was about to die?
When car goes under normal idle (almost die) its normal for the battery light to come on (not charging enaugh)....Fuel filter can NOT have its own code, as it has no electronics to it, its just a physical part that separates dirt from gas!
__________________
BIMMER HEAVEN
Specialized in BMW recycling, all OEM used parts
Up to 90% off new cost!!!
Most models E30 E36 E46 E90 E92 E93 E34 E39 E60 E32 E38 E65 E66 X3 X5 M3 M5 Z4


2nd location opening SOON!!!!

Call 11-8PM 416 821-2578
New inventory daily. 50+ cars in stock!
Eurostyle is offline   Reply With Quote
Old 05-04-2012, 11:19 PM   #10
BmW1819
6th Gear Member
 
Join Date: Feb 2007
Location: Pickering
Posts: 2,802
Bingo euro style
could be alot of things


Quote:
Originally Posted by Eurostyle View Post
When car goes under normal idle (almost die) its normal for the battery light to come on (not charging enaugh)....Fuel filter can NOT have its own code, as it has no electronics to it, its just a physical part that separates dirt from gas!
BmW1819 is offline   Reply With Quote
Old 05-04-2012, 11:24 PM   #11
Oyster
4th Gear Member
 
Join Date: Jun 2003
Location: Toronto
Posts: 653
Send a message via MSN to Oyster
happened to me, it was the MAF!
__________________
Oyster is offline   Reply With Quote
Old 05-04-2012, 11:31 PM   #12
Eurostyle
MaXsponsor
 
Eurostyle's Avatar
 
Join Date: Feb 2002
Location: Milton
Posts: 14,997
Quote:
Originally Posted by Oyster View Post
happened to me, it was the MAF!
Yes, i think the 1250 sounds familiar when i had to replace my MAF 2 years ago...
Or it was general missfire!
__________________
BIMMER HEAVEN
Specialized in BMW recycling, all OEM used parts
Up to 90% off new cost!!!
Most models E30 E36 E46 E90 E92 E93 E34 E39 E60 E32 E38 E65 E66 X3 X5 M3 M5 Z4


2nd location opening SOON!!!!

Call 11-8PM 416 821-2578
New inventory daily. 50+ cars in stock!
Eurostyle is offline   Reply With Quote
Old 05-28-2012, 11:49 PM   #13
Klipzs
1st Gear Newbie
 
Join Date: Feb 2012
Location: Canada
Posts: 43
Hey guys i appreciate the help.
My peake tool finally arrived and I did a scan and came up with these codes:
80 : EWS Signal
91 : EVAP small leak detected
dE : Coolant temp too low for closed loop operation

The small evap leak is not new to me, but the EWS Signal and the "Coolant temp too low for closed loop operation" are things I have never heard of.
Any idea what could be the problem?
Klipzs is offline   Reply With Quote
Old 05-29-2012, 06:46 AM   #14
sproule905
6th Gear Member
 
sproule905's Avatar
 
Join Date: Jul 2006
Location: The Landing
Posts: 1,328
Tstat and sensor. Good luck
__________________

sproule905 is offline   Reply With Quote
Old 06-02-2012, 04:26 PM   #15
Klipzs
1st Gear Newbie
 
Join Date: Feb 2012
Location: Canada
Posts: 43
Thank you. noob question but which sensor do you think i would need to replace?
Klipzs is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 05:25 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.