Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-09-2012, 06:48 PM   #121
E30M42cab
Parts Hoarding Specialist
 
E30M42cab's Avatar
 
Join Date: Apr 2006
Location: Milton
Posts: 2,333
Nah, the binding was so minimal, it shouldn't matter. We spun the nuckle around several times watching the rubber guibo and it was straight. We did a bang up job on the swap, but I think at this point it's probably a fluid issue. You could hook the PS back up and see if that solves it before buying all new PS bits. I've got a spare belt or two kicking around, Mr. Belt Cutter.
__________________

Quote:
Originally Posted by richie_s999 View Post
Grow up and move on.
E30M42cab is offline   Reply With Quote
Old 04-10-2012, 11:57 AM   #122
adam325i
3rd Gear Member
 
adam325i's Avatar
 
Join Date: Feb 2009
Location: Hamilton
Posts: 359
If you want to check your toe easy. Just grab a tape measure. With the car on the ground, take a measurement from tire to tire on the front side. *Make sure you use the same spot on each tire.(first tread groove on the inside of each tire) Measure the back side of the tires. Get those within 16th to 8th of an inch. Should be good to drive down to your alignment shop.

Hope that helps. I know a car out of alignment is like holding the reigns of a bucking horse.
__________________
90 325i 4dr Winter fun
90 325i 2dr Summer/track car
87 325i 4dr Parts
adam325i is offline   Reply With Quote
Old 04-10-2012, 06:10 PM   #123
desmo
AutoEmployee for Life
 
Join Date: Mar 2010
Location: Vaughan
Posts: 112
Car looks great out of the garage with the new parts! I took at look at your car a few months back when I bought the plastic bumper set from you (Which also looked great, thanks again)

Looking forward to seeing it in person this summer. Whens the first E30 drive? I did Forks of the Credit ALONE this weekend.
desmo is online now   Reply With Quote
Old 04-11-2012, 06:32 AM   #124
defaultName
5th Gear Member
 
Join Date: Mar 2010
Location: Mississauga
Posts: 963
Quote:
Originally Posted by E30M42cab View Post
You could hook the PS back up and see if that solves it before buying all new PS bits. I've got a spare belt or two kicking around, Mr. Belt Cutter.
Too late, parts are ordered!

I wanted to try deleting the power steering to see how it felt but I'm not sure I like it. Granted this isn't a very good test but it gave me an idea of what it would be like.

I don't think the trade off would be worth it for me.

Quote:
Originally Posted by adam325i View Post
like holding the reigns of a bucking horse.
This.

I took the car to get an alignment yesterday and I had to fight the car to keep it in my own lane! It was probably a 5 minute drive but I was terrified.

I ended up getting a call from the shop shortly after I dropped it off saying that it was pointless to do the alignment because the tires are completely destroyed.

It's not that they're flat or bald, apparently the tread is separating from the tire and that's a big part of why the car is driving that was (plus the alignment).

I wasn't planning on buying tires right away but I guess I have no choice.

Quote:
Originally Posted by desmo View Post
Car looks great out of the garage with the new parts! I took at look at your car a few months back when I bought the plastic bumper set from you (Which also looked great, thanks again)

Looking forward to seeing it in person this summer.
Thanks! I'm glad you like the bumpers, I'm sure the car looks great with them installed.

Quote:
Originally Posted by desmo View Post
Whens the first E30 drive?
Paging Scott
defaultName is offline   Reply With Quote
Old 04-11-2012, 07:19 AM   #125
richie_s999
6th Gear Member
 
Join Date: Sep 2008
Location: Oshawa
Posts: 4,537
Quote:
Originally Posted by desmo View Post
Car looks great out of the garage with the new parts! I took at look at your car a few months back when I bought the plastic bumper set from you (Which also looked great, thanks again)

Looking forward to seeing it in person this summer. Whens the first E30 drive? I did Forks of the Credit ALONE this weekend.
I hope you guy's all cruise out to Mosport on the 28th or 29th of this month and hang out at the Trillium BMW driving school.
richie_s999 is offline   Reply With Quote
Old 04-11-2012, 09:59 AM   #126
adam325i
3rd Gear Member
 
adam325i's Avatar
 
Join Date: Feb 2009
Location: Hamilton
Posts: 359
This.

I took the car to get an alignment yesterday and I had to fight the car to keep it in my own lane! It was probably a 5 minute drive but I was terrified.

I ended up getting a call from the shop shortly after I dropped it off saying that it was pointless to do the alignment because the tires are completely destroyed.

It's not that they're flat or bald, apparently the tread is separating from the tire and that's a big part of why the car is driving that was (plus the alignment).

I wasn't planning on buying tires right away but I guess I have no choice.


Ive had 2 tires that had belts broken. Tire wasn't round. Felt like the balance was off. I guess every little thing adds up.

Hope you find tires and get your alignment done and be silky smooth.
__________________
90 325i 4dr Winter fun
90 325i 2dr Summer/track car
87 325i 4dr Parts
adam325i is offline   Reply With Quote
Old 04-11-2012, 07:00 PM   #127
defaultName
5th Gear Member
 
Join Date: Mar 2010
Location: Mississauga
Posts: 963
Quote:
Originally Posted by defaultName View Post
Too late, parts are ordered!
...And they arrived!

The trunk on the Schwarz was always full of sand. It was like I was driving around on a beach with the trunk open and I never knew why. Scott pointed out when we were swapping the suspension that I was missing the gaskets so I ordered a couple. No more siliconed rear shock mounts!



Not sure why they used that size of a box to ship 2 gaskets...

Also picked up some parts to fix and reinstall my power steering.



I had to buy a new belt because someone suggested that I just cut mine off

There is one hose that costs about $200 which I didn't buy. I'm sure that will be the one that was leaking
defaultName is offline   Reply With Quote
Old 04-12-2012, 07:35 PM   #128
defaultName
5th Gear Member
 
Join Date: Mar 2010
Location: Mississauga
Posts: 963
Picked up some tires today and mounted them on my weaves. Dunlop Direzza DZ101's.



This is the first set of tires I have ever bought! I can't even count how many cars I've owned but I have never bought tires for them. New tires are so nice and they even smell good too.



I test fitted one of the wheels on the front before I ordered the tires and it just barely rubs on the brake carrier. The wheel still turns but I will need to grind down the carrier a little.

I did some digging on my wheels and it looks like they are made by RW Wheels from Belgium. They went out of business in the early 90's so I can't find much info about them. If anyone knows anything about them I would love to hear it!

My caps have BMW roundels on them but this is how their logo looks...



I wish I had time to refinish them before I mounted the tires but I am short on time
defaultName is offline   Reply With Quote
Old 04-12-2012, 10:03 PM   #129
defaultName
5th Gear Member
 
Join Date: Mar 2010
Location: Mississauga
Posts: 963
Quote:
Originally Posted by defaultName View Post
I will need to grind down the carrier a little.
...Okay so it turns out it's a little more then a little.
defaultName is offline   Reply With Quote
Old 04-12-2012, 10:10 PM   #130
SamE30e
6th Gear Member
 
SamE30e's Avatar
 
Join Date: Jul 2007
Location: Milton
Posts: 2,870
See. I told you to get the P/S parts.
__________________
91 318is - M50NV (gone)
02 WRB Subaru WRX EJ207 forged, 320 AWHP stock turbo.
85 - 325
02 325i Sedan
SamE30e is offline   Reply With Quote
Old 04-14-2012, 07:13 AM   #131
defaultName
5th Gear Member
 
Join Date: Mar 2010
Location: Mississauga
Posts: 963
Quote:
Originally Posted by SamE30e View Post
See. I told you to get the P/S parts.
defaultName is offline   Reply With Quote
Old 04-14-2012, 05:16 PM   #132
defaultName
5th Gear Member
 
Join Date: Mar 2010
Location: Mississauga
Posts: 963
Quote:
Originally Posted by defaultName View Post
I will need to grind down the carrier a little.
Quote:
Originally Posted by defaultName View Post
...Okay so it turns out it's a little more then a little.
...Okay so they did just need to be ground down a little, I was just grinding the wrong area.

Pics soon.
defaultName is offline   Reply With Quote
Old 04-14-2012, 06:28 PM   #133
defaultName
5th Gear Member
 
Join Date: Mar 2010
Location: Mississauga
Posts: 963
Overall I'm happy with the result. They don't stand out as much as I thought they would considering the offset.



The rear wheels could definitely use some spacers!



I think the kit makes the wheels look a little more sunk in then they actually are. M Tech II kits have a similar effect.

defaultName is offline   Reply With Quote
Old 04-21-2012, 07:15 AM   #134
defaultName
5th Gear Member
 
Join Date: Mar 2010
Location: Mississauga
Posts: 963
My car desperately needed an alignment and considering how bad it was there was no way I was going to drive it since I put new tires on it.

So...



Got bored following the tow truck.





But did the alignment fix the problem??? (drumroll please)






















F*CK YEAH ! ! ! The car drives straight and doesn't pull side to side! I can't believe that all of that was caused by a bad alignment... Lesson learned I guess.

Also since I have actually driven the car a bit now I can say that no power steering isn't toooo bad. When I'm stopped I can barely move the wheel, and it's very stiff when going slow, but since I won't be parallel parking daily or anything I think I can live with it for a while.

As for the Z3 rack it does feel quicker. Or I should say it doesn't feel as slow as a stock E30. I think I haven't felt a big difference in quickness because of 2 reasons. I haven't driven a stock E30 in a while so I probably forgot a little how slow the steering was. And for the last 2 months I've been driving a newer Kia which has zero steering feel, but it does have very quick steering. I'm sure someone driving an E30 with a stock rack and my car back to back would feel more of a difference then I did.
defaultName is offline   Reply With Quote
Old 04-21-2012, 08:21 AM   #135
lost
2nd Gear Member
 
lost's Avatar
 
Join Date: Feb 2005
Location: Windsor Area
Posts: 285
Schweet! That's awesome.
lost is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 09:20 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.