Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-13-2014, 10:44 PM   #106
Bullet Ride
Cars in Perpetual Repair
 
Bullet Ride's Avatar
 
Join Date: Nov 2007
Location: Guelph
Posts: 5,747
Then one day after work I was looking at the weldment for my linkage and thought that it was too heavy, so I started drawing on it with marker...



Because sharpie marker magically makes things lighter...



It was actually a rough guide for where I'd drill holes to give it the superleggera treatment. I never did take a picture of that, but it's nothing special, just drilling holes.

After that I set about putting everything back onto the car for the final test fit just to make sure everything would work the way it should. Once I got the linkage on the car with the cables a couple issues became glaringly obvious.

Firstly, I was building the throttle linkage on a motor that was sitting perfectly vertical on an engine stand. I never really considered too deeply the angle at which the throttle cable in the engine bay would have to enter the linkage in order for it to work properly. The plane of my linkage was parallel with the valve cover, but on the car the valve cover sits at quite an angle, I needed the plane of my linkage to be parallel with the ground, which meant I had to cut it off and re-position it.

The second issue that arose once the linkage was at the correct angle was that the pedal force required to open all 6 throttles was massive, like as stiff as my clutch pedal. That wasn't acceptable, but on top of that the fixed end of the throttle cable was now mounted to the bracket where the throttle cable was secured to the throttle body, which is only connected to the manifold by silicone couplers, so every time I pressed the gas the one set of throttle bodies was flexing up and down due to the heavy spring force.

I decided that I needed to tie the cable mount back to something solid. The simplest solution to me was to weld a brace that went back to the throttle linkage...



That made the throttle assembly nice and rigid and eliminated the flex.

Then I soldered on some mounting tabs to the vacuum manifold so it could mount up to the throttle bodies...



Unfortunately the brake booster got in the way of the second manifold so I had to shorten it...



After that I took apart the throttle bodies to remove some springs. Each set has 3 springs, so there were 6 springs in total, compare that to the 2 springs on the stock throttle body... it definitely felt 3x stiffer lol. Luckily it was easy to remove 2 of the 3 springs from each set of throttle bodies. With only one spring per set of throttle bodies the pedal felt much more like the stock pedal.

I realize that there is some inherent risk with removing the springs. Each throttle body should have a spring in case part of the linkage malfunctions or falls off, that way the throttle will always tend to shut. Without a spring, if something broke it could flap open and send one cylinder to WOT. I'm fairly confident in the robustness of the mechanism, but I'll make sure to inspect the parts on a regular basis to make sure everything is as it should be.

After that I took everything apart, cleaned it up, painted the linkage and manifold black and then put it all back together...



The throttle bodies came with a 3 wire TPS. I figured out which wires had to go where and spliced them into the harness. This TPS works the opposite as the E36 TPS I was using previously though. At zero throttle the voltage is high and at WOT the voltage is low. I did the calibration in tunerstudio and the TPS gauge was reading what my pedal was reading with a nice stable signal. However, much like the E36 TPS I had once the car was running the TPS signal became unstable. I figure there's probably some sort of grounding issue with the harness somewhere that's causing feedback, either that or it's a result of my alternator not giving a stable voltage signal (I have the pulsing headlights when the car is sitting idling currently... I need an alternator rebuild)

Also worth mentioning is that while the paint on the manifold was drying I synced up each set of throttle bodies. I did it using the shank of a very small diameter drill as a feeler gauge. I cranked the idle screw open on the throttle body until the drill would slide past the gap with some drag, much like doing a valve adjustment. Then I adjusted the sync screws on the other two throttles until all 3 had the same amount of drag then just cranked the idle screw back out. Once both sets were on the car I used the idle screw on the throttle linkage to open both sets and then used the threaded adjusters on the cables to make sure the drag felt the same across both sets. This should get me fairly close, and at some point I'll get a couple of vacuum gauges just to get them dialed in dead nuts.

Anyway, that pretty much sums up the mechanical side of things. The car did fire up and the MAP signal was stable enough for the car to idle normally.

Now the fuel maps need to be completely re-tuned. So I'm slowly working on that.
__________________
Bullet Ride is online now   Reply With Quote
Old 05-13-2014, 11:18 PM   #107
richie_s999
6th Gear Member
 
Join Date: Sep 2008
Location: Oshawa
Posts: 4,537
Looking forward to seeing and hearing it, will car be ready for Bimmercruise ?
richie_s999 is offline   Reply With Quote
Old 05-14-2014, 12:26 AM   #108
DIY
Permanently Dirty
 
DIY's Avatar
 
Join Date: Aug 2010
Location: Etobicoke
Posts: 533
And we all want to hear that beautiful noise!!!
__________________
DIY is offline   Reply With Quote
Old 05-14-2014, 01:00 AM   #109
craz azn
6th Gear Member
 
craz azn's Avatar
 
Join Date: Feb 2004
Location: Port Perry
Posts: 7,529
Send a message via MSN to craz azn
^ What he said!
__________________

Rippin' Proper | Youtube | Vimeo |
craz azn is online now   Reply With Quote
Old 05-14-2014, 01:32 AM   #110
everlast
if I lived . I would be ~
 
everlast's Avatar
 
Join Date: Mar 2004
Location: Ottawa
Posts: 5,847
I'd love to drive an e30 with ITB, like you say, heal toe would be effortless. I have to jam the throttle 1/2 second before I need it. You get used to it though.
__________________
everlast is offline   Reply With Quote
Old 05-14-2014, 09:09 AM   #111
Bullet Ride
Cars in Perpetual Repair
 
Bullet Ride's Avatar
 
Join Date: Nov 2007
Location: Guelph
Posts: 5,747
Quote:
Originally Posted by richie_s999 View Post
Looking forward to seeing and hearing it, will car be ready for Bimmercruise ?
Definitely. I was bummed that I missed it last year, and I want to get out on the all new DDT.

Quote:
Originally Posted by DIY View Post
And we all want to hear that beautiful noise!!!
Yes, of course... in due time
__________________
Bullet Ride is online now   Reply With Quote
Old 05-14-2014, 02:23 PM   #112
aviator
3rd Gear Member
 
Join Date: Aug 2013
Location: Toronto
Posts: 430
OK I get it now... thanks for the explanation... with 20 extra rwhp you might actually see a small improvement in mpg since it may take less throttle to get her moving at the desired speed... that is if you can control your happy foot ... I'm assuming to get this to work you also have some custom adjustable goodies in the computer too not just a stock motronic unit...
aviator is offline   Reply With Quote
Old 05-14-2014, 03:14 PM   #113
Bullet Ride
Cars in Perpetual Repair
 
Bullet Ride's Avatar
 
Join Date: Nov 2007
Location: Guelph
Posts: 5,747
Yeah, I was already running megasquirt before this.

The weather has been shit the past two days so I haven't been able to do any tuning... shitty. Hopefully this weekend will be better.
__________________
Bullet Ride is online now   Reply With Quote
Old 05-19-2014, 05:09 PM   #114
Bullet Ride
Cars in Perpetual Repair
 
Bullet Ride's Avatar
 
Join Date: Nov 2007
Location: Guelph
Posts: 5,747
Here are a couple of sound clips...


__________________
Bullet Ride is online now   Reply With Quote
Old 05-19-2014, 07:33 PM   #115
blk3
4th Gear Member
 
blk3's Avatar
 
Join Date: Nov 2009
Location: Oshawa On Canada
Posts: 833
Sounds pretty good. How does the car feel with the new setup?
__________________
blk3 is offline   Reply With Quote
Old 05-19-2014, 09:27 PM   #116
Bullet Ride
Cars in Perpetual Repair
 
Bullet Ride's Avatar
 
Join Date: Nov 2007
Location: Guelph
Posts: 5,747
Quote:
Originally Posted by blk3 View Post
Sounds pretty good. How does the car feel with the new setup?
It still needs some tuning, but it feels pretty good. I'm curious to see what the dyno says.
__________________
Bullet Ride is online now   Reply With Quote
Old 05-20-2014, 02:31 PM   #117
Yamahammer
Warlock of the century
 
Yamahammer's Avatar
 
Join Date: Jun 2010
Location: kitchener
Posts: 644
Ah nothing like finishing a 2 year project. hahaha.

Congrats man, sounds great.
Yamahammer is offline   Reply With Quote
Old 05-20-2014, 03:05 PM   #118
Bullet Ride
Cars in Perpetual Repair
 
Bullet Ride's Avatar
 
Join Date: Nov 2007
Location: Guelph
Posts: 5,747
Quote:
Originally Posted by Yamahammer View Post
Ah nothing like finishing a 2 year project. hahaha.

Congrats man, sounds great.
Yeah... now to start the next 2 year project... E21 body work lol
__________________
Bullet Ride is online now   Reply With Quote
Old 05-23-2014, 01:41 PM   #119
aviator
3rd Gear Member
 
Join Date: Aug 2013
Location: Toronto
Posts: 430
Sounds good... really smooth... be nice to find out what the dyno says about it... also be interesting to know if you have any mpg improvement [provided you can control your happy foot that is lol]
aviator is offline   Reply With Quote
Old 05-23-2014, 02:32 PM   #120
SiR
Vtec just kicked in
 
Join Date: Apr 2002
Location: TO
Posts: 2,740
nice work
__________________
-||Old Crayons||-
SiR is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 03:31 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014