Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > Z series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-02-2012, 01:58 AM   #1
Camm
2nd Gear Member
 
Camm's Avatar
 
Join Date: Apr 2012
Location: London, ON
Posts: 64
2006 Z4 Coupe - Starting problem

Car has been running perfectly. Today i park it, try starting a couple hours later, and a whirring, slightly shrill sound is coming from the engine bay. On the dash, an EML and engine check light is also on. I can hear something spinning, with the shrill sound, but not sure what. Engine wont start.

Otherwise all other light, and things are working.

Anyone know what this is?
Camm is offline   Reply With Quote
Old 09-03-2012, 10:37 AM   #2
propr'one
op sucks cock
 
propr'one's Avatar
 
Join Date: Jun 2004
Location: T.
Posts: 17,703
Send a message via MSN to propr'one
Scan the OBD code (partsource will do this free)
__________________
d1s bulb canada

Hot: 2001 Estoril M RoadsterZCP 19's michelin supersports, ZHP knob, JL 8W3
Cold: 2002 TiAg M3 6mt ZCP 19's michelin supersports, deoranged, dechromed, led tails, ZHP knob, UUC SS v3, GROM, OEM 18's w310's,
hid headlights hid kit
propr'one is offline   Reply With Quote
Old 09-03-2012, 10:47 AM   #3
bmwm5lover
is BMW crazy
 
bmwm5lover's Avatar
 
Join Date: Sep 2002
Location: Thornhill
Posts: 15,348
Im gonna say starter is not catching.
Not sure why the EML is on, perhaps it goes off once the car starts and does a full scan of systems but because car cannot start, it stays on while trying to start.
__________________
www.enthusiastauto.caNeed a car???

His--'00 BMW ///M5 .:Jet BLK/BLK:. Individual-1 of 1 - Style 65 Wheels; 9.5" Square Set up;275 Tires;10mm/3mm Spacers; Black Kidneys;Muffler Delete; 3.5" Dual Tips; Beast Power; "Dinan" Ducts; E60 SSK; BC Coils
Hers--'00 BMW ///M5 .:Avus Blue/Grey/Black:. 1 of 8
Toys
'88 BMW 635CSi Blue/Tan Sport
'81 MB 500 SEC Euro Koenig
bmwm5lover is offline   Reply With Quote
Old 09-08-2012, 10:09 AM   #4
Camm
2nd Gear Member
 
Camm's Avatar
 
Join Date: Apr 2012
Location: London, ON
Posts: 64
Thanks guys. It was the starter soloniod. Had a new starter put in at Bimmer Sport Automotive.

Any suggestions on rotors and brake pads? Am leaning toward Zimmerman or Brambo and Textar pads.
Camm is offline   Reply With Quote
Old 09-08-2012, 03:08 PM   #5
propr'one
op sucks cock
 
propr'one's Avatar
 
Join Date: Jun 2004
Location: T.
Posts: 17,703
Send a message via MSN to propr'one
i'd probably do brembo blanks. Personally i'm going to put EBC greens on my z
__________________
d1s bulb canada

Hot: 2001 Estoril M RoadsterZCP 19's michelin supersports, ZHP knob, JL 8W3
Cold: 2002 TiAg M3 6mt ZCP 19's michelin supersports, deoranged, dechromed, led tails, ZHP knob, UUC SS v3, GROM, OEM 18's w310's,
hid headlights hid kit
propr'one is offline   Reply With Quote
Reply

Tags
eml light, engine check, starting problem

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 07:58 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.